WordPress: Neuer Exploit kann auch Version 2.0.6. betreffen

11 01 2007

Nach den kürz­lich bekannt gewor­de­nen Sicher­heits­lü­cken in Word­Press 2.0.5. und der sehr zügi­gen Ver­öf­fent­li­chung des Updates 2.0.6. wurde nun eine wei­tere Schwach­stelle ent­deckt, die unter bestimm­ten Vor­aus­set­zun­gen auch der neu­es­ten WP-​Version gefähr­lich wer­den kann.

Das Pro­blem liegt in die­sem Fall aller­dings nicht ori­gi­när bei Word­Press son­dern beruht auf einem Feh­ler in den (unge­fix­ten) PHP Ver­sio­nen < 4.4.3. bzw. < 5.1.4. Panik machen gilt also nicht, son­dern am bes­ten sollte man erst mal die PHP–Ver­sion auf dem Web­host über­prü­fen. Am bes­ten mit der guten alten phpinfo.php, ein­fach eine Text­da­tei mit fol­gen­dem Inhalt anlegen:


< ?php
phpinfo();
?>

als phpinfo.php sichern und auf dem Webs­pace laden. Dann per domain​.de/​p​h​p​i​n​f​o.php (oder ähn­lich) auf­ru­fen und die Ver­sion überprüfen.

Sollte es sich um eine der feh­ler­haf­ten Ver­sio­nen han­deln (siehe oben), sollte man sei­nen Hos­ter kon­tak­tie­ren und ihn bit­ten, die Varia­ble register_globals auf off zu set­zen. Der Exploit funk­tio­niert näm­lich nur, wenn diese auf on steht. Bei der Gele­gen­heit sollte der Hos­ter mal gleich eine neuere PHP–Ver­sion ein­spie­len, denn der Feh­ler wirkt sich sicher auch auf andere Web­an­wen­dun­gen aus. Wahr­schein­lich sind diese PHP–Ver­sio­nen (unge­fixt) aber ohne­hin sel­ten anzutreffen.

—-

Unab­hän­gig davon steht nun doch das Mini-​Update auf Ver­sion 2.0.7. in der Pipe­line, mit dem u.a. die Pro­bleme mit Feed­bur­ner beho­ben wer­den. Ob in irgend­ei­ner Form auf die­sen neuen Exploit rea­giert wird ist unklar.